C64: Power, Datasette, and Keyboard solved!

Commodore 64 port of "Bombjack" loaded on a small CRT TVI’ve basically had my Commodore 64 sitting on the shelf since I bought it. The PSU was usable, but not trustworthy, so I’ve been reluctant to mess with it… but some time ago I did stop in to Jaycar and bought a switch-mode power supply that’ll do 2A and is adjustable to 5VDC (specifically, catalog number MP3316), figuring that I could frankenstein something together. I bought it, and then never even opened it.

The other day I was looking at stuff and I found someone in Germany making brand new power supplies for it, that look absolutely lovely, but all told would be about $160AUD to get it here and frankly I wasn’t sure I’d use the thing enough to warrant it, so I figured yesterday when I needed a break from thinking too hard that I might just use the toys I have and get a day’s worth of fun.

So I carefully sliced into my otherwise pristine C64 PSU, figured out which wires were 5VDC, clipped those and sealed them off, and then cut up a USB cable and spliced that in place. Taped everything up, fired it up and everything worked. None of the chips are hot, except the VIC-II which is pretty much always gonna warm up, and even it wasn’t scalding or anything.

I then set about trying to fix the keyboard, which mostly worked except the spacebar simply never responded. If I manage to find a disk drive, I’m not gonna get very far at typing LOAD "*",8,1 without the space bar, am I?

Desoldered the shiftlock switch (what a stupid design), removed approximately a bajillion screws, and set about inspecting things. I thought that the shift lock didn’t work either, and I noticed they shared a common trace, so I followed that back, checking continuity for everything all the way back to what I think is some sort of shift register (though I didn’t look at the part numbers to confirm this). Everything looked good, so I decided to test it with something conductive, and sure enough it worked… that suggested to me that the conductive coating on the pads was dirty or non-existent.

It looked fine, so I cleaned it with isopropyl (which I later read somewhere is not actually good for these keyboards? Might have made a mistake there), and sure enough it was good enough so I buttoned everything back up, soldered the shiftlock switch back in place and tested it out. Every key works now! It’s no mechanical keyboard, and some of them take quite a press to get it to register, but I won’t be typing any essays on it.

Thinking for something else to do, I went out to see what other bits and pieces came with it and found the Datasette. I thought it was weird that it was black, and it turns out it’s actually a 1531, not a 1530 - it’s designed for the Commodore Plus/4, among others, hence the black. It has the wrong connector for my Commodore, but helpfully came with an adaptor.

Took it apart to clean everything out and inspect everything. The belt is very loose (sometimes you have to tap it to get it to start moving), but once adjusting the connector to account for the incredibly corroded edge-pins on the C64 (I must stress it really looks like this thing spent at least some time outside or in a damp environment), it started loading something off a commercial tape. I wasn’t expecting much because of the condition of everything (all the disks are warped, everything smells mouldy) but it actually FOUND BOMBJACK after some seconds, and then continued on. It failed to load once or twice, but just as I was about to give up, it successfully loaded the entire game.

I tried a couple more commercial tapes and they too loaded after some attempts, I am fairly sure it works about 33% of the time. It might want adjusting, so I spent some time researching whether I could “align” it using an oscilloscope. I’m not 100% sure whether this possible, but I was able to learn that the “cassette read” pin should strobe at about 5VDC, with three possible pulse lengths, which I believe are around 672μs, 512μs, and 352μs (they coincide with multiples of the clock frequency of the C64, so these may not be right for my PAL unit).

Armed with this information I thought I might be able to at least check if they seem reasonable, so I unpacked my scope (which I haven’t used since well before we moved), and spent some time remembering how to use the damn thing. I thought I didn’t have the scopes configured correctly, because I was getting some weird readings (nonsensical AC ripples on what should be DC, but incredibly far out of whack, like at times 25VAC, suspciously at about 50Hz, which should have killed my C64 in an instant, I think?), but it turned out I had it mostly correct. After quite some time on a whim I tried the second scope probe and it turned out my yellow one was buggered - the earth lead on it is ratshit, so I didn’t have an earth for it to reference, and that was the reason for the weird AC. It worked fine with the purple probe, and the yellow probe also works fine if I use the earth of the purple one too (they share an earth). I didn’t save any screenshots of it but I managed to see perfect waveforms of 5VDC square waves, and if I’d set it to single trigger mode I suspect I probably could have manually decoded a few bytes too.

After all this time mucking with it, I’d actually managed to successfully load quite a few tapes, so I decided not to mess with the alignment just yet. But I am fairly sure with the condition of the drive belt that it’s probably the main factor - if it slips at the wrong time it will easily turn a short pulse into a medium or long one, so I decided to wait until I buy a new belt for it.

But do I? Loading from a tape absolutely sucked ass, getting a 1541-II was the absolute best thing to happen to my family in the 1980s, so why would I voluntarily subject myself to that? I found some seller on ebay selling the 1.5x1.5mm belts in a variety of lengths for about $5 for 10, shipped from China. What length do I need? The internet isn’t sure, but the range seems to be somewhere in the 75mm to 80mm diameter range, with most warn out belts being in excess of 85mm. I could spend $10 and wait a month for both sizes to come from China…

… or I could simply buy some sort of disk+tape emulator off ebay for about 5x that and not have to deal with dodgy tapes, and be able to load any game I want after downloading the ROM from the internet (Super Pipeline maybe?). I’m definitely thinking that’s the more likely approach. But at least the thing is “working”, for some definition of working.

Horsham, VIC, Australia fwaggle

Published:


Modified:


Filed under:


Location:

Horsham, VIC, Australia

Navigation: Older Entry Newer Entry