For the last couple of weeks, our car's been making this annoying rapid ticking sound when the indicators are off. I had my theories as to what caused this, but searching some forums confirmed it - the indicator stalk has got excess play. I reckon the problem is that the flasher module is activated without it being connected to either side indicator circuit, so you get the rapid flashing like you do when a lamp is out.

Anyway, last Friday I purchased a replacement on eBay - $22AUD, cheap enough for a gamble. It arrived today just after lunch, and I braved the heat to install it, which is a rather painless job if you know what you're doing (removing the steering column cover is not intuitive whatsoever).

Drop the steering wheel, squeeze the front (closest to the steering wheel) of the top half together and it pops right off. Undo the phillips head screw in the bottom, slide the bottom half forward until it falls off. The indicator stalk itself has two tabs on the top and bottom, simply squeeze them and pull it out. Undo the two plugs, and the third plug for the cruise control (if fitted), then replace doing the opposite of the removal procedure.

I turned the key on, the ticking is gone, and the indicator action itself is much more positive. It feels so nice that if we had more money to burn, I'd contemplate replacing the windshield wiper stalk too.

Horsham, VIC, Australia fwaggle

Published:


Modified:

Never

Filed under:


Location:

Horsham, VIC, Australia

Navigation: Older Entry Newer Entry